Belajar site to site VPN Cisco Router

Kali ini berlajar konfigurasi Cisco Router sebagai VPN. Maksudnya adalah setiap traffik yang melewati router antara 2 titik (site to site) akan di enkripsi. Sehingga pertukaran data antara 2 router ini akan jauh lebih aman. Dan seolah – olah mempunyai jalur sendiri di Internet (ISP). Topologi tampak di bawah ini :

Langsung kita mulai LAB dengan GNS3 kita. Dan konfigurasikan seperti di atas. Berikut konfigurasi untuk router 1 :

hostname R1

!

crypto isakmp policy 7

encr aes

authentication pre-share

group 2

lifetime 100

!

crypto isakmp key vpnkey address 10.10.2.2 no-xauth

!

crypto ipsec transform-set vpntrans esp-aes esp-sha-hmac

!

crypto map vpn-map 10 ipsec-isakmp

set peer 10.10.2.2

set transform-set vpntrans

match address vpn-acl

interface Loopback0

ip address 192.168.1.1 255.255.255.0

!

interface FastEthernet0/0

ip address 10.10.1.1 255.255.255.0

crypto map vpn-map

!

router rip

version 2

network 10.0.0.0

network 192.168.1.0

no auto-summary

!

ip access-list extended vpn-acl

permit ip 10.10.1.0 0.0.0.255 192.168.0.0 0.0.255.255

Jangan lupa untuk menambahkan perintah no shutdown disetiap interface agar interface aktif. Berikutnya kita setting R3 (ISP).

hostname R3

!

interface FastEthernet0/0

ip address 10.10.1.3 255.255.255.0

!

interface FastEthernet1/0

ip address 10.10.2.3 255.255.255.0

duplex auto

speed auto

!

router rip

version 2

network 10.0.0.0

no auto-summary

!

Selanjutnya kita beralih ke R2 :

!

hostname R2

!

crypto isakmp policy 7

encr aes

authentication pre-share

group 2

lifetime 100

crypto isakmp key vpnkey address 10.10.1.1 no-xauth

!

crypto ipsec transform-set vpntrans esp-aes esp-sha-hmac

!

crypto map vpn-map 10 ipsec-isakmp

set peer 10.10.1.1

set transform-set vpntrans

match address vpn-acl

!

interface Loopback0

ip address 192.168.4.2 255.255.255.0

!

interface FastEthernet0/0

ip address 10.10.2.2 255.255.255.0

duplex auto

speed auto

crypto map vpn-map

!

router rip

version 2

network 10.0.0.0

network 192.168.2.0

network 192.168.3.0

network 192.168.4.0

!

ip access-list extended vpn-acl

permit ip 192.168.0.0 0.0.255.255 10.10.1.0 0.0.0.255

!

Baiklah, semua konfigurasi telah berjalan dengan baik. Sekarang kita lakukan ujicoba dan pengecekan. Dengan cara perintah ping dari R1 ke R2 :

perintah ping dan Show crypto ipsec sa

Perhatikan gambar di atas, perintah ping dari R1 menuju R2. IP tujuan di R2 adalah IP loopback yaitu 192.168.4.2, kita ibaratkan 192.168.4.2 adalah alamat LAN lokal di bagian R2. Selanjutnya show crypto ipsec sa adalah pengecekan paket yang terenkripsi. perhatikan ada paket yang error “send errors 1” dan “pkts encaps : 4” total nya ada 5 paket yaitu sesuai dengan paket ping yang baru saja yang kita kirimkan.

Jika ada pertanyaan dan saran dipersilahkan.

semoga bermanfaat, terima kasih.😛

4 responses

  1. mas, pakai router tipe berapa di gns? kalo tutorialnya di praktekin di packet tracert bisa ga ya?

  2. sangat bermanfaat, buat bahan ujian tentang jaringan.

  3. assalamualaikum, mas mau tanya kalo di ccna assignment itu boleh tidak mengerjakan assignment chapter 3 dlu baru mengerjakan yg 2 karena telah masuk di chapter tersebut dan telat mengerjakan chapter 2? tapi instruktur saya bilang nanti assigment itu dibuka lagi. mohon infonya. trmksh

    1. waalaykumsalam.

      dulu sih gak bisa mbak… kalo yang sekarang saya gak update lagi nih..😀

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: